1
Vote

UsersDisp.aspx Error

description

Just installed this tool, clicked on the FBA User Management link and I got the error below
 
Object reference not set to an instance of an object. at CKS.FormsBasedAuthentication.FBAUsersView.ExecuteSelect(DataSourceSelectArguments selectArgs)
at System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback)
at System.Web.UI.WebControls.DataBoundControl.PerformSelect()
at System.Web.UI.WebControls.BaseDataBoundControl.DataBind()
at System.Web.UI.WebControls.GridView.DataBind()
at System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound()
at System.Web.UI.WebControls.CompositeDataBoundControl.CreateChildControls()
at System.Web.UI.Control.EnsureChildControls()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

comments

Bill732 wrote Jun 30, 2008 at 5:01 PM

I have run into this as well. I have the the site set up with dual authentication. I set it up pretty much according to Andrew Connell's instructions (http://www.andrewconnell.com/blog/articles/HowToConfigPublishingSiteWithDualAuthProvidersAndAnonAccess.aspx) except that I have the public facing web site (his http://internet) in the "default" zone instead of the "internet" zone. I had to do it this way because the site already existed in the "default" zone. I haven't had any issues with this arrangement, so I don't think that is the problem.

I deployed the solution to the windows authenticating website because that is where we plan to do the user management. I do have the connection strings, membership provider, role provider, etc. in the web.config files of both the windows authenticating app and forms authenticating app. Both seem to be able to find users in the database.

The FBA Membership Request Management page opens fine. Just the FBA User Management page errors as described by rideon88.

Bill732 wrote Jul 3, 2008 at 1:46 PM

pculmsee reported the same problem on this post http://www.codeplex.com/CKS/Thread/View.aspx?ThreadId=16363 and has more information. Replies suggest checking permissions on database. I've tried adding Moss app pool account and the moss set up account. No luck so far.

Rockie wrote Nov 15, 2010 at 7:30 AM

Same issue

wrote Feb 14, 2013 at 1:10 AM