wss 3.0 form authenticaion--urgent help plz

Topics: Forms Based Authentication, SharePoint
Sep 12, 2007 at 10:22 PM
hi ..
am trying to change wss3.0 page to forms authentication.
i added connection string and authentication(aspnetmembershipprovider) in web.config
and made necessary chages in application management too.
i created two users in the db and when i try to login it says.
Error:access denied
you are logged in as : my username
signin as diff user..

plz help me wat to do..!
thanks
Sep 13, 2007 at 8:31 AM
Have you already assigned those users to a visitor or member SharePoint group? It seems as if your newly created users don't have any rights on your web application. Apparently your forms authentication is set up correctly as you receive the login screen and the access denied error.
Sep 13, 2007 at 11:45 AM
i dnt how to add those users to those users to members of sharepoint group.
i dnt know how to do add those users under forms.
can you plz tell me how to do that
Sep 13, 2007 at 12:23 PM
You do it exactly the same as adding Active Directory users to a SharePoint group.
If you have created users in your forms based credentials store, you can even use the people picker to retrieve them upon adding them to a SharePoint group.
Sep 13, 2007 at 2:46 PM
Edited Sep 13, 2007 at 2:48 PM
hi.. thanks for your reply..
am all of first not able to log in to the site..
wat ever user i give its not getting in .
am geting the error as
"
Error access denied:
you are logged in as:jai
"

i gave to system userid and pass its not goin it
i even gave the userid and pass which the application pool calls up. its too not getting logged in.
in what user id and pass i should log in to check and make other users to log


and one more thing is that
if we get into the application management and tried to give the primary site users and seconday site user am not able to find any user with aspnetmembership providing..
Sep 14, 2007 at 3:00 PM
Two things to check.
1) Make sure that your Publishing Web Application's, Central Administration and your Shared Service Provider AppPool accounts have access to the aspnetdb database. Grant all Aspnet_* rights to those accounts. Actualy only your publishing Web Site AppPool account needs FullAccess access as it will be the only one creating stuf, but start with this.

2) Double...quadruple check your web.config file. A single misplaced caracter will screw things up.

NOTE: Your first SQL user needs to be Site Collection Owner. That's done in Central Admin. You need Central Admin to have the provider configured otherwise it will never resolve your SQL users. So step 1; have Central Admin resolve SQL users. This will also make sure your web.config provider configuration is valide for your publishing site(s) and your SSP.

Hope it helps.
Sep 14, 2007 at 5:21 PM
hi...
thanks for your reply...
after i gave the full permission as you said in the db for the user in the appln pool now my users in the db are able to loging.
but after loggin with the users who live in my db are with only read permission..
they look like the visitor to the site.

what will the user for admin control.
am not able to find the admin user for to gettin into my site.


in teh appln mangement for to give primary and seconday administrator
am not able to find any users..
can you plz help me to getting login into my admin control.

thanks
Sep 14, 2007 at 6:33 PM
The problem is in your Central Admin's web.config file. Note that you cannot use Groups for Site Collection Admin. It must be a user.

Once you fix this problem, logon to your site with the SQL Site Collection Admin. Go in the Site Settings and add SQL users to appropriate SharePoint Groups.
Sep 14, 2007 at 7:17 PM
hi..
thanks for your reply..
where will be web.config for cental admin will be localted ?
and what chage should i make in tat web.config to make it work ?
Sep 14, 2007 at 8:21 PM
Check out thi site: http://blog.chinaunix.net/u/14738/showart_271546.html
Sep 14, 2007 at 8:43 PM
hi ..
thanks for reply ..
i ll chcek the url and ttry my hands..
thnxk again
Sep 17, 2007 at 7:14 AM
hi..
thnx for your reply..
i did sme changes in the web.config file
now able able to login with my users in the db
but am not able to login as the administrator...
wat to do?
Aug 29, 2008 at 8:41 PM
sweetraskels, I am really struggling with that web.config file. I don't think I have it configured right at all. Would it be possible to see what you have done either by posting or emailing me?
Aug 29, 2008 at 8:46 PM
hi .. plz post ur web.config file or send a mail to sweetraskels@gmail.com
and tell me the steps ur did on achieve it